Главная FAQ для PH#2 ver1.0

FAQ Оглавление.

  • О программе.

  • Часть 1 - Создание тестов.

  • Часть 2 - Тестирование.

  • Часть 3 - Контроль.

  • Часть 4 - Администрация.

    • Copyright Aklin(c) 2005.


FAQ для PH#2 ver1.0. О программе.

В главное меню.
Copyright Aklin(c) 2005.

О программе.

PH#2(c) - программа для создания всевозможных тестов, тестирования и контроливания процесса тестирования.

Программа была создана по идейному образцу программы PHYSIX(c), но алгоритм работы программы кардинально изменён. Программа дважды переделывалась заново, и первая версия не предлагала того же, что и вторая версия. Вторая версия написана с учётом ошибок и недоработок и Physix и первой версии программы.
Подробнее можно узнать в разделах Создание тестов, Тестирование, Контроль, Преимущества.

Автор программы и идеи построения | Aklin(c)
Непосредственный создатель | Aklin(c)
Конструктор идеи построения | Aklin(c)
Все права принадлежат | Aklin(c)
Обратная связь
Сайт программы + обновления
Сайт автора
Последнее обновление ON-line HELP
Copyright Aklin(c) 2005


HELP для PH#2 ver1.0

В главное меню.
Copyright Aklin(c) 2005.

Администрация.

Что есть такое.

Здесь будут описаны настройки, доступные Администратору (он же АДМИН).

Поехали.

Для входа в часть АДМИН мы используем... Правильно, пароль. Войдя в часть админ нажимаем Настройки. Спускаемся до конца скроллом (тем, что справа), И натыкаемся на табличку ПАРОЛЬ. Для избежания "левых" ситуаций я добавил поле "старый пароль". Итак, вводим старый пароль, вводим новый пароль.

-ААА! вы ошиблись, и ввели новый пароль, но ошиблись в одном знаке (что случается со всеми).

Дабы не ввести неверный (или случайный) новый пароль, Предусмотрено поле дубляжа. Приехали, ввели ВЕРНЫЙ старый пароль, новый пароль, и ВЕРНО его продублированли. Нажмём кнопку "Изменить". Если всё нормально, новый пароль будет принят и будет считаться ПАРОЛЕМ.

Ничего не понимаю. (Язык, короче)

Скорее всего вы читаете по-русски, а написано , скажем, по-английски. В программе предусмотрена функция смены языка трансляции.

Вообще, если не будет ни единого языка трансляции, вы скорее всего увидите лишь пустые кнопки. Файлы языков именют маску *=LANG.TXT , где * -любая комбинация букв алфавита (желательно английского), также нерекомендованы прочие сомволы. Примечание. Некоторые фразы хранятся в других файлах (/ZERO/FACE/Main.ini , а также в папке скинов)

Так вот. Вы решили изменить язык трансляции. Ну что ж, это не запрещено. Для этого во всё том же режиме АДМИН Выберите Настройки-Язык трансляции. Далее !выберите! из списка искомый язык.
Примечание. Если вы точно знаете название языка, а список длинный, вы можете набрать название в специальном поле. После выбора, !ЕСЛИ ДАННЫЙ ФАЙЛ СУЩЕСТВУЕТ!, то отобразится (ниже списка) примерный текст данного языка. ЕСЛИ ФАЙЛ НЕ НАЙДЕН (прим. отсутствие пробной строки не означает отсутствие файла), то вы не сможете ИЗМЕНИТЬ ЯЗЫК ТРАНСЛЯЦИИ. Для окончательного закрепления материала, нажмите "Изменить". При этом если файл существует, то язык измениться, если нет - будет соответсвующее предупреждение.
Примечание. Данный параметр вступит в силу только после перезагрузки (ДАЖЕ ЯЗЫК части АДМИН НЕ изменится).

Ничего не вижу. (Скины, короче)

Для приятного проведения процесса тестирования в программе предусмотрены так называемые "СКИНЫ". Скины - это сменяющийся внешний вид элементов. К примеру по-умолчанию установлены простйшие, даже скажу стандартные скины, во всём похожие на Windows. Точнее их вообще нет.

Но как я уже сказал, для более приятного проведения теста, предусмотрены скины. Скины действуют только в зоне тестирования, т.к. ДЛЯ снижения быстроты работы в части АДМИН они не используются.

Итак. Вы всё же решили сменить скины. Для этого в рамке "скины" необходимо выбрать нужные скины. Примечание. Для отключения скинов (процесс тестирования ещё ускоряется) введите пустую строку. После выбора под списком должны отобразиться примерные изображения. Вообще изображения должны появиться. Иначе... скинов нет. Итак. Вводим (или выбираем) скины, полсе чего нажимаем "Изменить". Всё. Скины записаны и сохранены. Кстати возможно отсутствие файлов (если скины не отключены), что приведёт к соответствующему сообщению. Для изменения скинов необходимо и достаточно перезапустить программу (а не перезагрузить компьютер)

Прочие примечания.

Во-первых, скины и язык транслирования можно изменить, да вообще много чего там можно изменить, в файле \ZERO\SYS.ini Откроем файл и начнём. (Секция - это надпись в [***], свойство - это надпись (НЕ В НАЗВАНИИ СЕКЦИИ) до знака равно, значение - после. (пример : [water] - секция water, temp=10 , где temp - свойство, а 10 - значение свойства temp секции water.))
Секция. | Свойство. | Что означает, допустимые значения.
[ADDED] | 0 -3 | 0 - типы файлов, относящиеся к "тестовым", 1-к картинкам и изображениям, 2-к аудио, звукам и музыке, 3-к Видео. Убедительная просьба, НЕ ЗАПИСЫВАЙТЕ ТУДА ВСЕ ТИПЫ файлов, встречающиеся на вашем компьютере. Дочтаточно 2-4.
[Advance]. | Skin | Название текущих скинов. Если вы точно уверены, можете изменить.
[Advance] | ILand | Текущий язык. Аналогично изменимо.
[Advance] | Logs=1 Logs=0 | Включить(1) или выключить(0) системные логи. Учтите: 1) логи занимают до 30 килобайт за один тест, или вход в часть админ. 2)Логи помогут мне быстро разобраться в ситуации возникновения ошибки : просто опишите ситуацию и прикрепите файл /ZERO/SYS.log Но можно после ошибки подключить их и повторить ситуацию, хотя это снижает точность проверки мною ошибки.

Ну что ещё (АНКЕТА)

Всё об анкете регистрации см. ЗДЕСЬ.

Буду очень признателен, если кто-нибудь решится, создаст и пришлёт МНЕ новые языки, скины, анкеты.

В главное меню.
Copyright Aklin(c) 2005.


FAQ для PH#2 ver1.0 Админстратор. Режим АДМИН.

В главное меню.
Copyright Aklin(c) 2005.

Администратор.

Администратором программы называется лицо(частное), имеющее доступ к части админ.

По умолчанию администратором назначается человек, установивший программу на свой компьютер. Никто кроме него не является администратором. Передача права администратора может быть только при условии(по соглашению с пользователем соглашения) полного переноса прав пользователя соглашения на другое лицо. При этом последнему сообщается пароль для входа в чать админ(при его наличии) .

Доступ права админ разрешён только администратору.

Для входа в чать админ необходимо после запуска программы ввести в поле ввода имени слово ADMIN любым регистром только английским алфавитом. После этого необходимо ввести пароль, установленный администратором (по умолчанию - см. соглашение). После ввода корректного пароля программа перейдёт в режим админ.

Режим АДМИН.

В режиме админ вы (администратор) можете изменять настойки программы (подробнее см. настойки админ'а), запускать редактор тестов, ознакомиться со статистикой. Для более подробной информацией см. соответсвующие разделы.

В главное меню.


HELP для PH#2 ver1.0

В главное меню.
Copyright Aklin(c) 2005.

Анкета регистрации.

Да.. не очень хотел заполнять этот раздел - слишком он большой. Ну ладно.

Во-первых обозначаим, что есть что. Создание анкеты (я здесь и дальше буду иметь в виду создание с нуля) аналогично среднему из : создания HTML странички и программирования. Начнём? Откройте файл REG=RA.txt, файл должен называться ТОЛЬКо ТАК!

Для сождания анкеты есть следующие инструменты : Лейбл (она же простая надпись), Поле ввода, тестовое поле (больше, на несколько строк), метка и способность закгрузки файлов. Вы обозначаете новый элемент, и далее работаете только с ним до обозначения нового. Я попробую отдельно написать пример для одного элемента. Также есть общие параметры для работы со всей анкетой в общем.

Общие параметры.

Обозначение нового элемента : new=***; Вообще все свойства делятся на общие и уникальные.
Свойство | Написание | Что означает, допустимые значения.
Ширина | W=* W=%* | Ширина, выражена в твипах (15 твипов на пиксель) или в процентах от текущего положения до края расстояния. Процентое соотношение !начинается с %!
Высота | H=* H=%* | Высота, всё аналогично ширине.
Текст надписи | TXT=*** CAP=*** | Вообще в зависимости от ситуции, где TXT, где CAP. Хотя функция одна и та же.
Размер шрифта | FS=* | Размер как размер. от 1 до 600
Шрифт | FN=* | Аналогично, но шрифт должен существовать.
Цвет шрифта | FC=RRRGGGBBB | Цвет по системе RGB, где RRR и проч. от 0 до 255.
Тип шрифта | FT=BIUS | 1-вкл, 0-выкл, пример 0011, 1010... B-Жирный, I-Курсив, U-Подчерк, S-Зачерк.
Цвет элемента | FC=RRRGGGBBB | Цвет по системе RGB, где RRR и проч. от 0 до 255.
Выравнивание объекта | SA=* | Выравнивание, 0-лево, 1-право, 2-центр от начального положения до конца формы.
Скрипт | Script=*** | У всех, кроме лейблов, СМ. ниже.

Лейбл (LABEL)

Обозначения нового элемента : new=lbl; Униакльные параметры.
Прозрачность | VBS=* | 1-прозрачный, 0-нет
Вмятость | VBR=* | 1-вмятость, 0-нет
Выравнивание надписи | LGN=* | Выравнивание надписи относительно элемента. 0-лево, 1-право, 2-центр.
Авторазмер | LAS=* | 0-размер фиксирован, 1-определяется напдисью.

Тестоваое поле (TEXT)

Обозначения нового элемента : new=TXT; Униакльные параметры.
Вмятость | VBR=* | 1-вмятость, 0-нет
Выравнивание надписи | LGN=* | Выравнивание надписи относительно элемента. 0-лево, 1-право, 2-центр.
Вместительность | MAX=* | Наибольшее для ввода количество символов.
Преобразуется в "рассказ о себе".

Поле ввода (INPUT)

Обозначения нового элемента : new=INP; Униакльные параметры.
Вмятость | VBR=* | 1-вмятость, 0-нет
Выравнивание надписи | LGN=* | Выравнивание надписи относительно элемента. 0-лево, 1-право, 2-центр.
Вместительность | MAX=* | Наибольшее для ввода количество символов.
Маска | PCH=* | 1 символ маски, например *
Преобразуется в значение строки.

Метка (CHECK)

Обозначения нового элемента : new=CHECK; Уникальный параметр.
Начальное значение. VAL=* 1 - обозначено,0 - не обозначено
Преобразуется в ДА-НЕТ

Загрузка файлов (LOADING)

Обозначения нового элемента : new=LOAD;Уникальных параметров нет.

Общие параметры.

Обозначение : параметр начинается с буквы "A"
Задать положение | AX=* AY=* | Задать положение по х или у. в твипах
Отступ от текущего положения. | APX=* APY=* | Отступ в твипах от текущего положения по х вправо, у вниз.
Цвет фона | ABS=RRRBBBGGG | Цвет в формате RGB
Перевод строки | ANL | Перевод текущего положения на новую строку, действует только до команды new=*** или других общих команд
Строка регистрации и скриптов. | ATRS=* | СМ. Скрипты, скрипт RETURN.

Скрипты

Скрипты помогают обрабатывать полученное значение после нажатия кнопки ГОТОВО. Скрипты записываются после параметра SCRIPT=<СКРИПТ>; Для каждого скрипта нужно записывать слово SCRIPT;
Название | Элемент | Синтаксис | Допустимые значения.
Длинна строки | TXT INP | LEN:?* | вместо ? ставить ><= , вместо * количество сомволов (от 0 до 65536)
Обязательный | INP LOAD | REQ | Длинна поля ввода должна быть не нулевой, загруженный файл должен быть.
Тип файла | LOAD | TYPE:* | * соответственно : 0-текст, 1-изображения, 2-звуки, 3-видео.
RETURN: | INP, TXT, CHECK, LOAD | RETURN:* | см.ниже

Отдельный разговор или скрипт RETURN

В статистике можно увидеть данные, заполненные юзером в анкете. Для этого и существует данный скрипт. Во-первых надо сформировать строку возврата. Осущетвляется в начале (почти в самом). Записываем : ATRS=NAME:%NAME_GROUP:%GROUP_<Надпись>:%<строка возврата>_
Обязательно указать _ в конце строки! Например, в скриптах поля ввода запишем скрипт
SCRIPT=RETURN:DATE;
а строка будет такой (!!!обязательно укажите NAME:%NAME_GROUP:%GROUP_ и обознаьчте соответствующие поля!!! иначе регистрация невозможна!!!) ATRS=NAME:%NAME_GROUP:%GROUP_Дата рождения:%DATE.
ДАЖЕ если все команды не обязательно писать большим регистром, то эту строку - обязательно!!!
В результате значение (скажем 10.01.0110) , введённое в данное поле вы увидите в статистике так:
Дата рождения : 10.01.0110
Таким образом вы можете записать немало параметров. В стандартной анкете их 8 (ФИО, группа, дата родения, оценка по математике, физике, "вы сказали правду", фотография, о себе).

Прочие дополнения

Все параметры действуют только на последний введённый элемент, если он ошибочный или не походит (скажет вмятость для CHECK), то игнорируется. Но если скаже высота=-100, то ошибка. Все параметры записываются через ";" , при написании не учитывается регистр (за искл. всего, что связано с RETURN) и переводы строк.

Ну, ладно, пример

Пример для поля ввода ( ФИО ).
atrs=NAME:%NAME_GROUP:%GROUP_Фио:%NAME_;apx=200;apy=120; new=inp;w=%20;h=200;vbr=1;lgn=2;fs=14; fc=255255255;c=000255000;script=len:>1;script=len:<10;script=return:group;
Разбор полётов.
Отделный параметр | Что делает.
ATRS=NAME:%NAME_GROUP:%GROUP_Фио:%FIO_; | Зададим строку возврата.
apx=20;apy=120;/td> | Сместим текущее положение на 200 твипов вправо и на 120 вниз. Кстати, необязательно писать эти две команды вместе.
new=inp; | Создадим новый INPUT
W=%20;h=200; | Установим ширину в 20% расстояния от "сюда" до "края" и высоту в 200 твипов. Аналогично их вместе можно не писать.
vbr=1; | "вомнём"
lgn=2; | Пусть тектс будет посередине.
FS=12;FC=255255255; | Установим шрифт размеры 12 и белого цвета.
C=000255000; | Придадим зелёный цвет.
script=len:>1;script=len:<10;script=return:name;script=return:group;script=return:fio; | Скрипты, означающие, что длинна должна быть от1 до 10 символов, и возвращающее одновременно имя, группу и ФИО.
anl; | Переведём строку.

В главное меню.


Главная FAQ для PH#2 ver1.0

FAQ Оглавление.

  • О программе.

  • Часть 1 - Создание тестов.

    • Во-первых...
    Общие настройки, рекактироваие текста и типа вопроса, вариантов ответов.
    Редактирование оценки вопроса.
    Редактирование математики. Вложения.

  • Часть 2 - Тестирование.

  • Часть 3 - Контроль.

  • Часть 4 - Администрация.

    • Copyright Aklin(c) 2005.


Главная FAQ для PH#2 ver1.0

FAQ Оглавление.

  • О программе.

  • Часть 1 - Создание тестов.

  • Часть 2 - Тестирование.

  • Часть 3 - Контроль.

    • Статистика.
    Логистика.

  • Часть 4 - Администрация.

    • Copyright Aklin(c) 2005.


FAQ для PH#2 ver1.0 RTF-формат

В главное меню.
Copyright Aklin(c) 2005.

RTF-формат.

RTF-формат (далее RTF) отображения тестовых файлов и документов.

RTF позволяет:
  • Редактировать стиль и шрифт любого куска текста, предложения, слова или буквы. (жирный, наклон, подчерк, другой стиль)
  • Выбирать шрифт, размер шрифта, его написание и кодировку.
  • Вставлять различные вложения (картинки, таблицы, другое), связывать с документом различные приложения.

    • Подробнее см. MS WordPad (для вызова : "Старт"("Satrt") - "Выполнить"("RUN") - "write" - Enter.

    В главное меню.


HELP для PH#2 ver1.0 Тестирование.

В главное меню.
Copyright Aklin(c) 2005.

Шаг 1.

Начнем с начала, остальные присоединятся позже.
В самом первом окне проверим, нет ли нас в списке.
Введём нашу группу и убедимся, что в списке имён нашео нет.
Вообще в противном случае кто-то вошёл под вашим именем, обратитесь к администратору.

Не обнаружено.

Что ж. продолжим.
Нажимаем кнопочку регистрация.
Появиться окошко с формой регистрации, составленное администратором.
(Форма полностью создана администратором.)
Заполняем поля (ну о том, как это делать вам не у меня спрашивать).
(прим. разрешены символы :
ABCDEFGHIJKLMNOPQRSTUVWXYZАБВГДЕЁЖЗИЙКЛМНОПРСТУФХЦЧШЩЬЫЪЭЮЯ 1234567890.,()!@#
)

Нажмём кнопку ГОТОВО.

Если всё нормально, а такое бывает в 80% случаев, вас зарегистрируют.

Далее выбираем тест (вообще группа и имя должны быть выбраны) и нажимем "тест".
Ну что же...

Шаг 2.

Загружается форма с тестом.

Рассмотрим Первый Случай,

суть которого заключается в том, что в прошлый раз ВЫ не завершили или под ВАШИМ именем не завершили тест.
Т.Е. Тестируемся... и вдруг произошла ошибка. Теоретически на 70-80% процентов тест можно восстановить аж до 100%.
Так вот, перед вами на выбор:
А)Продолжить не завершенный тест. (70-80% стабильности)
Б)Начхать и идти дальше.
В)А может это не вы? Выйдите из программы за уточнениями.

Случай Второй,

Суть которого заключается собственно в тестировании.
Перед вами вопросы, требующие ответа.
Отвечаем, желательно правильно.

Шаг 3.

Подведение итогов.
После прохождения (!!! не стремитесь выйти !!!) вам будет выведен список ваших ошибок.
Вот это и есть ваш результат. Его можно показать кому надо.

В главное меню.


HELP для PH#2 ver1.0 : Во-первых...

Во-первых...

Ну, для начала необходимо зайти в часть админ.
Как это сделать? (прим. описание для версии p2850 и выше)

В первом же окне вместо имени надо ввести слово ADMIN любым регистром.
Вошли?
Далее должно появиться окно а-ля "Введи пароль"

Войдем!

Вводим пароль, нажимаем что нужно, а далее входим в собственно часть АДМИН.
Выбираем "Создание" в верхнем меню.

Ну вот, пришли.

Здесь спокойно можно копировать (нажатием "копировать") !выбранный! тест. Также можно указать имя копии.
Можно также создать новый тест, указав при этом имя первенца.
Примечание! Если нужно создавать все тесты по шаблону, вы можете создать тест и поместить его в папку "/Zero/Free/" все файлы из папки "шаблонного" теста.(см.папку "Data")

Отредактируем.

Для этого выберем тест и кликнем дважды (или нажмём "редактировать").
Менюшка с потолка уйдёт и появиться таблица с вопросами из теста.
Выйти из неё можно Esc, или нажав "Выход".

Добрались и до вопросов.

Здесь можно:
Копировать !выбранный! тест, создать новый.
А также редактировать опять же выбранный вопрос.
Выберем вопрос кликнем дважды. Или нажмём "редактировать".
Ну а далее здесь.

В главное меню. Часть 1 Часть 2 Часть 3
Copyright Aklin(c) 2005.


FAQ для PH#2 ver 1.0 Редактирование вопроса. Часть 1.

Создание тестирования.

Программа позваляет администратору и только ему создавать тесты.
Для этого выберите тест (или создайте новый) и запустите программу редактирования теста.

Вы можете редактировать уже имеющиеся вопросы теста, создавать новые или копировать уже имеющиеся.

Для редактирования выберите вопрос в таблице, нажмите "Выбранное"-"Редактировать". Откроется окно редактирования вопроса. Для копирования или удаления воспользуйтесь тем же меню.

Общие настройки.

Для выбора этого редактора нажмите "Общие настройки."
в общих настройках вы можете указать количество вопросов из всего списка а также настроить сообщение, появляющееся после окончания теста (формируется по "%p1" из таблицы).
ПОМНИТЕ!
После добавления или удаления вопросов измените параметр "Количество вопросов в тесте"!
ПОМНИТЕ!
После нажатия кнопки OK в этом сообщении программа прекращает работу, и узанть итоговую оценку возможно только при просмотре LOG-файлов или Логистики.
Также длинна сообщения ограничена (ну 20000 симболов не войдут) Настойте сообщение согласно вашим пожеланиям.
Скрипты, используемые в сообщении.
Написание | Что означает
%nm | вставить имя тестируемого.
%r1-%r8 | Вставить : 1-баллов за сейчас, 2-баллов вообще, 3-баллов макс. сейчас, 4-баллов макс вообще, 5-правильных отвтов сейчас, 6-вообще, 7-вопросов сейчас, 8-вопросов пройдено вообще.
%p1-%p4 | СМ.Пред. строку. p1=100%*r1/r2; p2=100%*r3/r4; p3=100%*r5/r6; p4=100%*r7/r8; Огр: r2,4,6,8 не равны 0 -> выдача 0. Ошибка - выдача 0. Округляется до 1 знака после запятой.
%st | Перенос строки.
Пример : %p1 От 10 до 40 : Уважаемый (ая) %nm ! %st Вы набрали %r1 из %r2 баллов т.е. %p1% %st Оценка 2. Получим:
Уважаемый(ая) Петя !
Вы набрали 2 из 10 баллов т.е. 20%
Оценка 2.

Редактирование вопроса.

Перед вами окно редактирования вопроса. Изменить текст вопроса вы можете выбрав "Окно"-"Шаг 1" (выбрано по-умолчанию)
Интерфейс позволяет вам редактировать вопрос посредством программы. Вы также можете загрузить готовый текст вопроса, созданный в формате RTF.
Для загрузки готового текста нажимете "Импорт данных из RTF файла."
ПОМНИТЕ!
Импорт больших по объёму (более 15Kb) файлов НЕРЕКОМЕНДОВАН! Используйте большие файлы только при крайней необходимости. Не вставляйте картинки и прочие вложения/приложения. Для этого существует раздел "ПРИЛОЖЕННЫЕ ФАЙЛЫ"! Использование файлов объёмом более 5Kb не шифруется для ускорения работы программы. (подробнее см. "Что нового")

Редактирование вариантов ответов.

Для выбора этого редактора нажмите "Окно"-"Шаг 2"
Вы можете выбирать тип вопроса (тип предоставления вариантов ответов) из существующих.
Вы можете добвлять[+], редактировать[R], удалять[-], вставлять в список[>] новые варианты , редактировать существующие (без оговорок для типов вопроса "переключатель" и "метка"). Набрав вариант ответа в поле ввода, вы можете добавить его в список и не удалять из поля ввода[+- он же + ]. Для выполнения этих действий надо нажать кнопки, указанные с скобках.
Назначить правильный ответ можно выбрав правильный ответ прямо в окне (для "меток" или "переключателей").

Примечание.

Для типа вопроса "поле вода" можно редактировать начальное значение !либо в поле ввода вариантов[+], либо в поле ввода самого ответа(внизу окна)!, Назначать надпись[C], редактировать правильный ответ (!в особо отведённом для этого поле ввода!).(подробнее см. "Что нового")

В главное меню. Часть 2 Часть 3
Copyright Aklin(c) 2005.


FAQ для PH#2 ver 1.0 Редактирование вопроса. Часть 2.

Редактирование заценки.(~оценки)

Для выбора этого редактора нажмите "Окно"-"Шаг 3"
Для редактирования необходимо выбрать тип оценивания результата : За весь ответ в целом, или для кождого варианта ответа по отдельности.
1)Для всего в целом.
Для этого переустаустановите переключатель в положение "За ответ в целом", введите значения (от -499 до 499) , которые будут начислены за верный и сняты за неверный ответ. (Верный=100% соответствие)
ПРИМЕР
за "верно" | за "неверно" | Ответ ВЕРНЫЙ | Ответ НЕВЕРНЫЙ
1 | 0 | Плюс 1 правильный ответ (счетчик правльный ответов) | Ничего
1 | 1 | Плюс 1 правильный ответ | Минус 1 правильный ответ
0 | 1 | Ничего | Счетчик неправльных ответов
-1 | 1 | Ответ зачтён как неверный | Ответ зачтён как неверный
1 | -1 | Ответ зачтён как верный | Ответ зачтён как верный
-1 | -1 | Ответ зачтён как неверный | Ответ зачтён как верный

2)Каждый в отдельности. Для "меток" и "переключателей" : Если выбране - занчит "ДА", не выбран - "НЕТ". Для "поле ввода"
маленький ПРИМЕР1 (везде назначение : да 1; нет -1)
Вариант 1 | Вариант 2 | Вариант 3 | Тип вопроса | Итог
да | да | да | "метка" | 3 балла
да | нет | да | "метка" | 1 балл
нет | да | нет | "метка"или "переключатель" | -1 балл
маленький ПРИМЕР2 (для "поле ввода")
ОТ | ДО | Баллы | введено | Значание
-100 | -20 | -400 | 30 | +0 баллов
-100 | -20 | -400 | 30 | +0 баллов
-20 | 20 | -100 | 10 | -100 баллов
20 | 100 | 400 | 30 | +40 баллов

В главное меню. Часть 1 Часть 3
Copyright Aklin(c) 2005.


FAQ для PH#2 ver 1.0 Редактирование вопроса. Часть 3.

Редактирование Математики.

Для выбора этого редактора нажмите "Окно"-"Шаг 4"
Вы можете создать до 20 переменных (ограничено beta версией как приемлимое)
Далее, выбирая номер переменной в бегунке, введите её значение. После нажмите Добавить к списку[+], также удалить из списка выбранное [-], Добавить и оставить [ + ] а также изменить добавленный в список пункт математики.
(подробнее см. "Что нового")
ПОМНИТЕ!
Важно следование команд по порядку. Вообще математика выполняется по принципу программирования - Замени две сроки для получения разных результатов.
Все вычисления выполняются в типе данных Double. Помните, что вычисления компьютера (!НЕ программы!) не являются абсолютно точными, но быстрыми.
Математические функции, включенные в версию 1.0 (регистр букв не важен)
Написание | Пример использования | Название и примечания
+ - * / \ ^ | 1+2*3/4\5^6 | Сложение, вычитание, умножение, деление, деление без остатака, возведение в степень. (3 посл. с соотв. огр.)(соотв.)
ABS | ABS(-10)=10;ABS(10)=1;ABS(0)=0 | Модуль числа
ATN | ATN(1)=pi/4 | Арктангенс. От -pi/2 до pi/2. pi не является встроенной константой.
Cos,Sin,Tan | Cos(0)=1;Sin(-pi/2)=-1;Tan(pi/4)=1 | Косинус, синус и тангенс соотв. (c соотв. огр.)
EXP | EXP(1)=e;EXP(2)=e*e | Экспонента. Прим. е не является встроенной константой. e=exp(1)
LOG | LOG(2.71)~~1;LOG(EXP(x))=x | Логарифм натуральный. (с соотв. огр.)
SQR | SQR(4)=2; SQR(16)=4; | Корень арифметический. (с соотв. огр.)
INT | INT(10)=10;INT(10.22)=10;INT(-10.56)=-11 | Целое арифметическое..
SGN | SGN(-10)=-1; SGN(10)=1; SGN(0)=0; | Знак числа арифметический.
!GET! | GET(1) | Вставка значения переменной (в данном случае 1)(с соотв. огр.)
RN0-RN6 | RN0(10.55)=11;RN3(10.555555)=10.556; | Округление от 0 до 6 знака после запятой.
RND | RND(10)=4.1246;rnd(10)=8.15434;RND(10)=2.8556765 | Случайное программное. Вообще 6 знаков после запятой.

Добавление вложений

Для выбора этого редактора нажмите "Окно"-"Шаг 5"
Вложения файлы, находящиеся в непосредственной доступности для программы. Эти файлы могут быть 4 типов: ТЕКСТ , ИЗОБРАЖЕНИЯ , АУДИО , ВИДЕО.
Вообще можно добавить до 20 файлов (определено beta версие как оптимальное). Для добавления нажмите ДОБАВИТЬ и выберите тип добавляемого файла. Затем выберите файл с помощью окно "Открыть". Для удаления выбранного файла из списка нажмите "Удалить".
ОБЯЗЯТЕЛЬНО подпишите файлы. Т.к. Подпись файлов необходима для их различия. В процессе тестирования сам файл виден не будет, а будет видна подпись. Нажам на подпись в увидите файл в специальном просмтотрщике.
В главное меню. Часть 1 Часть 2
Copyright Aklin(c) 2005.


HELP для PH#2 ver1.0 Логистика.

В главное меню. Статистика. Логистика.

Логистика.

Что есть что.

Логистика, она же ЛОГИ-статистика, что звучит хуже.
Во-первых надо зайти в часть АДМИН.
Далее надо зайти в отдел Статистики. Далее Выбрать "Статистика."
Логистика есть обобщенные результаты со всех проведённых тестов.
Вы получите результаты за каждый тест, кем, когда и что именно что за тест.

Таблица.

Наименование. | Что означает.
Ф.И.О. | Фамилия, Имя, Отчество юзера, введённое им в анкете регистрации (см. Здесь, Шаг1 ).
Группа. | Группа юзера, введённое им в анкете регистрации (см. Здесь, Шаг1 ).
Тест. | Название пройденного теста.
Дата. | Когда тест был пройден.
БЛЛ. | Количество полученных баллов.
ПрО. | Количество правильных ответов.

Copyright Aklin(c) 2005.
В главное меню. Статистика. Логистика.


HELP для PH#2 ver1.0 Статистика.

В главное меню. Статистика. Логистика.

Статистика.

Что есть что.

Во-первых надо зайти в часть АДМИН.
Далее надо зайти в отдел Статистики. Далее Выбрать "Статистика."
Статистика Есть обобщенные данные по всем юзерам и всем проведённым данным юзерам тестов.
Короче, юзер прошел тест, все результаты записались в статистику. Прошел ещё один тест, данные суммировалиь и записались вновь.

Таблица.

Наименование. | Что означает.
Ф.И.О. | Фамилия, Имя, Отчество юзера, введённое им в анкете регистрации (см. Здесь, Шаг1 ).
Группа. | Группа юзера, введённое им в анкете регистрации (см. Здесь, Шаг1 ).
Рез№1. | Количество баллов за правильные ответы.
Рез№2. | Максимально возможное количество баллов за правильные ответы. Определяется количеством баллов, которые АДМИН назначил за правильные ответ (классика) или за выбор всех пунктов (психологические).
Рез№3. | Количество правильных ответов.
Рез№4. | Максимально возможное количество правильных ответов. Определяется аналогично Рез№2.
%%%№1. | Фактическое отнешение РЕЗ№1/РЕЗ№2, выражено в процентах. Исключения : РЕЗ№2=0; РЕЗ№1<0; РЕЗ№2<0. При исключении отношение равно 0.
%%%№2. | Фактическое отнешение РЕЗ№3/РЕЗ№4, выражено в процентах. Исключения аналогичны %%%№1

Copyright Aklin(c) 2005.
В главное меню. Статистика. Логистика.